Back to overview
Degraded

API performance degraded

May 12, 2026 at 1:29pm UTC
Affected services
API

Resolved
May 12, 2026 at 1:33pm UTC

API recovered.

Created
May 12, 2026 at 1:29pm UTC

We are currently experiencing degraded API performance due to elevated demand. Our team is actively scaling backend capacity to restore normal response times. We will provide updates as the situation progves.