Service Degradation – Resolved
Resolved
May 12, 2026 at 4:04pm UTC
Today between 14:00 and 16:00 UTC, some users may have experienced slower response times lasting approximately 20 minutes.
What happened
During a scheduled deployment of a new version, a database migration was executed on our members table — one of our largest datasets. This operation temporarily increased database load and caused slower API response times across the platform.
Additionally, we identified a misconfigured scaling trigger on our API layer that was not responding optimally under increased load. This has been corrected as part of the same deployment.
What we fixed
- Completed the members table migration with minimal further disruption
- Corrected the API scaling trigger configuration to respond more effectively under load
Current status
All systems are operating normally. The improvements made will ensure better stability and faster recovery during future deployments.
Affected services